Logo 12.14

Die Version 12.14 wurde am May 24, 2022 veröffentlicht. Nachfolgend sind die wichtigsten Änderungen aufgeführt.

 

Highlights

Überarbeitetes Modell Unterhalt

Das Modell Unterhalt wurde aufgrund der bereits gemachten Erfahrungen und den neuen Möglichkeiten, die Logo12 bietet, überarbeitet. Die wichtigsten Änderungen sind:

Einheitliche Zuweisung von Tätigkeiten

Die Zuweisung von Tätigkeiten ist nun in allen Ansichten und bei allen Objekttypen einheitlich. Über das Attribut Aktualisierung Tätigkeiten wird gesteuert, ob für ein Objekt die im Katalog definierten Standardtätigkeiten oder frei wählbare objektspezifische Tätigkeiten gelten.

Tätigkeiten sind neu immer Katalogzuweisungen, der Objekttyp Tätigkeiten wurde entfernt. Zudem werden Tätigkeiten neu direkt mit dem Typenkatalog der verschiedenen Objekttypen verknüpft, der Katalog Unterhaltstyp entfällt.

Sichtbarkeit von Ausführungen

In den jeweiligen Hauptansichten sind die Ausführungen als Unterobjekte der Unterhaltsobjekte sichtbar. In der Ansicht Unterhalt sind nur Ausführungen sichtbar, die in einem Auftrag enthalten sind.

Beispiel Grünfläche in der Ansicht Inventar:

Ausführungen in der Ansicht Unterhalt:

Einfügen neuer Ausführungen

In den jeweiligen Hauptansichten können Ausführungen entweder einzeln manuell oder für ausgewählte Objekte automatisch über die Funktion Auswahl > Ausführungen erstellen eingefügt werden. Beim automatischen Erstellen werden für alle zugewiesenen Tätigkeiten geplante Ausführungen in der vorgegebenen Häufigkeit für das aktuelle Kalenderjahr erstellt.

In der Ansicht Unterhalt können Ausführungen nach wie vor nur über die Funktion Auftrag > Ausführungen hinzufügen erstellt werden.

Status und Ausführungsdatum

Status und Ausführungsdatum des Auftrages werden neu automatisch aus den Ausführungen übernommen. Dies verunmöglicht widersprüchliche Informationen bei Auftrag und Ausführungen und stellt eine gewisse Datenkonsistenz sicher. Um Status und Datum der Ausführungen eines Auftrages zu bearbeiten, steht die bereits aus Logo11 bekannte Funktion Status und Datum aktualisieren im Tab Auftrag zur Verfügung.

Ausführungen können neu auch unabhängig von Unterhalt lizenziert und verwendet werden. Die Auftragsplanung in der Ansicht Unterhalt steht dann nicht zur Verfügung.

Neue Ansichten für Verkehrsdaten

Das Datenmodell für Verkehrsdaten wurde vereinfacht und umfasst neu zwei verschiedene Ansichten, um die verschiedenen Zusammenhänge abzubilden.

Neu ist ein Querschnitt immer nur einer Messstelle untergeordnet. Der Zusammenhang zwischen Messstelle, Querschnitt, Richtung und Messspur, ist in der Ansicht Messstellen ersichtlich:

Für den Strassenbezug gibt es eine neue Ansicht Querschnitte, wo der Zusammenhang von Achsen und Querschnitten ersichtlich ist. Messstelle, Richtungen und Spuren sind hier als Unterobjekte des Querschnittes aufgeführt.

In beiden Ansichten steht zudem neu eine kombinierte Attributtabelle Verkehrsdaten zur Verfügung, welche sowohl Verkehrsdatenabschnitte (unabhängige Objekte mit Verkehrsdaten) als auch Messdatenabschnitte (Objekte mit Verkehrsdaten aus Messungen) beinhaltet. Die Spalten in dieser Tabelle sind fix und können nicht verändert werden.

 

Neue Ansicht Hilfssegmente

Neu steht für die Verwendung von Hilfssegmenten eine eigene Ansicht zur Verfügung. Die Idee dahinter ist, dass Hilfssegmente beispielsweise aus dem Datensatz TLM Strasse importiert und fix in Logo geführt werden können. Über die externe ID können die Hilfssegmente bei Änderungen jederzeit mit dem externen Datensatz synchronisiert und die Achsgeometrien so nachgeführt werden.

In dieser Ansicht ist es neu auch möglich, Hilfssegmente zu führen, die (noch) mit keinem Achssegment verknüpft sind. Aus solchen Hilfssegmenten können neue Achssegmente erstellt werden, dies ist vor allem beim Aufsetzen neuer Logo-Projekte hilfreich.


Neue Funktionen

  • Alle Filter im Fenster Objekte deaktivieren - Die Möglichkeit, alle gesetzten Filter im Fenster Objekte mit einem Klick zu deaktivieren, ist in der Kopfzeile des Fensters wieder vorhanden. Dahingegen wurde die Möglichkeit, Attributfilter einzeln ein- und auszuschalten, entfernt.

  • Geometrie mit einer bestehenden Linie verschneiden - Neu können die Geometrien von Objekten mit bereits bestehenden Linien-Objekten verschnitten werden. Ein Anwendungsbeispiel aus der Praxis sind beispielsweise Grünflächen, die mit Zäunen verschnitten werden.

  • Multipart-Geometrien mit einer Linie verschneiden - Neu können Objekte mit Multipart-Geometrien mit einer Linie so verschnitten werden, dass aus einer Teilgeometrie ein eigenes Objekt entsteht.

  • Objekte mit gemeinsamer Geometrie - Neu ist es für gewisse Objekttypen möglich, Objekte in unterschiedlichen Ansichten mit einer gemeinsamen Geometrie zu erfassen. Ein Beispiel aus der Praxis sind Kandelaber, die in den Ansichten Belechtung, Signale und Elektromechanische Anlagen geführt werden. Solche Objekte haben nur Position und Ausdehnung gemeinsam, die Attribute entsprechen nach wie vor den unterschiedlichen Objekttypen in den verschiedenen Ansichten.

  • Neuer Objekttyp Lärmmindernde Beläge - In der Ansicht Projekte steht neu der Objekttyp Lärmmindernder Belag zur Verfügung (kostenpflichtiges Feature).

  • Neue Auswahlfunktionen - Unter Start > Auswählen stehen neu die beiden Möglichkeiten, alle Objekte eines bestimmten Objekttyps oder alle Unterobjekte des aktuellen Objektes eines bestimmten Typs auszuwählen.

  • Deckelhöhe von Entwässerungsschächten aus Shapefile mit Z-Koordinaten übernehmen - Werden Entwässerungsschächte aus einem Shapefile mit Höhenwerten (Z-Koordinate) importiert bzw. synchronisiert, werden neu die Höhenwerte als Deckelhöhen verwendet, sofern dieser Wert bei einem Schacht nicht bereits abgefüllt ist. Diese Werte lassen sich im Nachhinein immer auch manuell überschreiben.

  • Darstellung des Zustands für Entwässerungsobjekte - Für Objekte in der Ansicht Entwässerung steht neu die Darstellungsoption Letzte Bewertung zur Verfügung. Mit dieser wird die Zustandsbewertung aus der letzten Überwachung in der Karte dargestellt.

  • Report-Vorlagen in verschiedenen Sprachen einbinden - Neu können Report-Vorlagen in verschiedenen Sprachen eingebunden werden. Die Vorlagen müssen dazu in MyTemplates in den Verzeichnissen DE, FR oder IT abgelegt werden. Wird ein Report ausgegeben, wird zuerst die Vorlage in der Sprache gesucht, in der Logo eingestellt ist. Wird keine Vorlage in dieser Sprache gefunden, wird die Vorlage in Deutsch verwendet.

  • Werkreparaturen nachträglich mit anderen Objekten verknüpfen - Werkreparaturen können neu in der gleichnamigen Ansicht nachträglich mit einem anderen Objekt verknüpft werden. Beim Attribut Referenziertes Objekt werden Objekte im Umkreis von 20 m aufgelistet, dort kann eines ausgewählt werden.

  • Neue Funktion Spurende korrigieren - Mit der neuen Funktion Spurende korrigieren können Spurenden ans Segmentende angepasst werden. Nach Auswahl der Funktion muss in der Karte der Punkt auf einem Achssegment gewählt werden, ab dem alle Stützpunkte der Spur auf das Lot des Segmentendes projiziert werden sollen. Danach kann die vorgeschlagenen neue Geometrie übernommen oder verworfen werden.

  • Allgemeine vordefinierte Zusatzthemen - Neu stehen in der Zusatzthemenverwaltung vordefinierte Zusatzthemen zur Verfügung. Unter Zusatzthema erstellen > Vordefinierte Zusatzthemen können einfach Hintergrundkarten von Google oder swisstopo eingebunden werden.

  • Benutzerrechte für ganze Themenbereiche vergeben - Neu können einer Benutzergruppe Rechte für ganze Themenbereiche vergeben werden. Diese Rechte werden auf Gruppenebene vergeben und für die enthaltenen Objekttypen übernommen. Abweichende Rechte können auf Ebene Objekttyp weiterhin einzeln festgelegt werden.

 


Verbesserungen

  • Objekt in anderer Ansicht anzeigen - Wollte man sich ein Objekt in einer anderen Ansicht anzeigen lassen, war dies aufgrund von aktiven Filtern oft nicht möglich. Neu wird deshalb der Filter, der die Anzeige des gewünschten Objektes verhindert, deaktiviert und das Objekt angezeigt. Der Filter muss danach manuell wieder aktiviert werden.

  • Ausgewählte Dateien in ein anderes Objekt verschieben - Das Verschieben von Dateien über Drag-and-drop war nie sehr praktisch, deshalb können Dateien neu ausgewählt und verschoben werden. Dazu die Dateien in der Objektliste selektieren, zum Zielobjekt wechseln und im Tab Auswahl > Objekte verschieben > Dateien ausführen.

  • Report-Vorlagen werden nur noch aus einem Verzeichnis gelesen - Da es in der Vergangenheit immer wieder zu Problemen mit verschiedenen Versionen von Report-Vorlagen und unterschiedlichen Ablagen gekommen ist, liest Logo neu nur noch Vorlagen aus dem Verzeichnis, welches in den Einstellungen unter Eigene Vorlagen angegeben ist. Das Verzeichnis Templates im Logo-Verzeichnis dient nur noch der Distribution von Vorlagen und kann nicht mehr als Vorlagen-Verzeichnis angegeben werden.

  • Neue Attribute für Beläge und Belagsschichten - Bei den Objekttypen Belag und Schicht stehen neu die Attribute Bauleiter bzw. Ausdehnung auf Spur, Frästiefe, Fläche, Rezeptur und Kurzbeschrieb zur Verfügung.

  • Ältere Zeitstände im Querprofil Strasse - Neu können im Querprofil Strasse auch ältere Zeitstände angezeigt werden, sofern diese Daten vorhanden sind. Die vorhandenen Objekte können im Dropdown oben rechts nach Gültigkeit gefiltert werden.

  • Verbesserung Verhalten der Legende im Achsband - Die Legende des Achsbands verhält sich nun gleich wie die Legende in der Karte, d. h. bei Katalogen mit Schwellenwerten oder Kategorien werden immer alle Einträge angezeigt, bei Katalogen mit Einzelwerten nur die Einträge, die in der Karte bzw. im Achsband vorhanden sind.

  • Achsband mit Legende drucken - Neu kann beim Ausdrucken des Achsbands auch die Legende ausgedruckt werden.

  • Mehrsprachige Metainformationen - Neu können Metainformationen und Hinweise zu einzelnen Attributen in den Einstellungen mehrsprachig erfasst werden.

  • Feld Höhe m ü.M. bei Basispunkten - Bei Basispunkten steht neu das Feld Höhe m ü.M. zur Verfügung.

  • Direkte Bearbeitung der Attribute beim Mehrfacheinfügen von Unterobjekten - Neu wird beim Mehrfacheinfügen von Unterobjekten für ausgewählte Objekte das Fenster Attribute bearbeiten direkt geöffnet. So können Unterobjekte in einem Schritt eingefügt und Attribute mit Werten abgefüllt werden.

  • Nur noch sichtbare Objekttypen in der Einfügen-Galerie - Neu werden Objekttypen, welche über den Filter ausgeblendet wurden, auch in der Einfügen-Galerie im Tab Einfügen ausgeblendet. Dies erhöht die Übersicht und vereinfacht die Bedienung.

  • Massstabseinstellung für die Darstellung in der Karte pro Objekttyp - Neu können die Massstabsgrenzen für die Kartendarstellung für die meisten Objekttypen einzeln definiert werden. Objekte auf Spuren bzw. Achsen haben gemeinsame Einstellungen und die Einstellung für einzelne Objekttypen gelten in allen Ansichten, in der dieser Objekttyp vorkommt.

  • Strassennamen neu in Ansicht Kataster - der Objekttyp Strassennamen ist neu nicht mehr in der Ansicht Achsen, sondern in der Ansicht Kataster untergebracht. Der Filter Strassennamen wurde zudem aus dem Seitenpanel entfernt.